xref: /aosp_15_r20/external/coreboot/util/nixshell/devshell-i386.nix (revision b9411a12aaaa7e1e6a6fb7c5e057f44ee179a49c)
1with import <nixpkgs> {};
2
3pkgs.mkShell {
4	name = "coreboot-devshell-i386";
5
6	packages = [
7		cacert
8		gdb
9		git
10		qemu
11	];
12
13	buildInputs = [
14		ncurses
15		openssl
16	];
17
18	nativeBuildInputs = [
19		coreboot-toolchain.i386
20		pkg-config
21		openssh
22	];
23
24	shellHook = ''
25		# In Nix, stdenv sets a STRIP environment variable, which has conflict
26		# with libpayload/Makefile.payload. Unset the variable.
27		unset STRIP
28	'';
29}
30