xref: /libbtbb/packaging/libbtbb.spec (revision 5cf4c9cb441aa735be0ac77081632db31c920700)
1#
2#Copyright 2013 Dominic Spill
3#
4#This file is part of libbtbb
5#
6#This program is free software; you can redistribute it and/or modify
7#it under the terms of the GNU General Public License as published by
8#the Free Software Foundation; either version 2, or (at your option)
9#any later version.
10#
11#This program is distributed in the hope that it will be useful,
12#but WITHOUT ANY WARRANTY; without even the implied warranty of
13#MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14#GNU General Public License for more details.
15#
16#You should have received a copy of the GNU General Public License
17#along with libbtbb; see the file COPYING.  If not, write to
18#the Free Software Foundation, Inc., 51 Franklin Street,
19#Boston, MA 02110-1301, USA.
20#
21
22Summary: Bluetooth baseband library
23Name:    libbtbb
24Version: 2013.06
25Release: 1
26Summary: A Bluetooth basebad decoding library
27License: GPLv2
28URL:     http://mooedit.sourceforge.net/
29Source:  %{name}-%{version}.tar.gz
30
31BuildRequires:  cmake gcc python
32
33Autoreqprov:    on
34
35%description
36A library for decoding and processing Bluetooth baseband packets.
37It can be used with any raw bitstream receiver, such as Ubertooth or
38gr-bluetooth.
39
40%prep
41%setup -q
42%build
43cmake -DCMAKE_SKIP_RPATH=ON \
44      -DCMAKE_INSTALL_PREFIX=%{_prefix} \
45	  -DBUILD_ROOT=%{buildroot}
46
47%{__make} %{?jobs:-j%jobs}
48
49%install
50%{__make} DESTDIR=%{buildroot} install
51
52%files
53%{_prefix}/lib/libbtbb.so
54%{_prefix}/lib/libbtbb.so.0
55%{_prefix}/lib/libbtbb.so.0.2.0
56%{_prefix}/lib/python*
57%{_bindir}/btaptap
58%{_libdir}/../include/libbtbb/bluetooth_le_packet.h
59%{_libdir}/../include/libbtbb/btbb.h
60%doc COPYING README.md
61
62%changelog
63* Thu Jun 06 2013 Dominic Spill <dominincgs@gmail.com> - 0.2.0
64- First binary release
65